GUI Texture as background is hiding other objects in scene

I’ve used GUI Texture as background and resized it for different resolutions. But the problem is that it hides the other objects in the scene. IS there any solution for this ?

You can make this work by having two cameras and putting your GUITexture on a different layer:

  • Create a new camera. Set the name to ‘Background Camera’
  • Set the ‘Depth’ to -1 on the Background camera.
  • Create a new layer (Layer dropdown in upper right). Call the layer ‘Background’.
  • Set the Culling Mask of the Background camera to ‘Background’ (set it to ‘Nothing’ then select ‘Background’).
  • Add your GUI Texture. Set its Layer to ‘Background’.
  • On the Main Camera, turn off ‘Background’ in the Culling Mask.
  • On the Main Camera, set ‘Clear Flags’ to ‘Depth only’.
  • On the Background Camera, turn off ‘Audio Listener’.

it doesnt work to me in unity 5.5