Hands are occluded by objects in unbounded volumes since 1.1.4

Hello!

Since updating to Polyspatial 1.1.4, my hands and arms have started being occluded by gameobjects in scenes with unbounded volumes. Scenes with bounded volumes still seem to be working as intended. This is true both when run through the editor via Play to Device, and when built to the device directly. I was able to see my hands in the same scenes while on 1.0.3. I also created a new project using the 1.1.4 template and am experiencing the same issue.

My headset is on version 1.1 beta 2. Would updating to beta 4 possibly help? I know beta versions aren’t supported, so I’m worried it may break more if I do.

Thanks for the help!

We’ve just enabled this as a setting in the Apple visionOS settings in XR Plug-in Management called Upper Limb Visability. For an MR app you’ll want to check this one (it defaults to off).

2 Likes

I actually already tried that while I was looking through the settings, but it didn’t seem to change anything. I’m still unable to see my hands or arms in front of objects, even with it checked.

Update: The setting does work for builds, but it does not seem to work with Play to Device. When I rebuilt my project with the setting checked and installed it to the headset I was able to see my hands, but they are still blocked in Play to Device.

1 Like

Noted, yeah there are some features not supported in play to device (but it’s not documented). Glad the check box is working though.

1 Like