Has anyone had a camera jitter issue with Unity 2018.1 Timeline objects?


I’m working on a VR film at the moment. For some reason, in one of the scenes, the characters are really jittery while in the others the characters move normally. The weird thing is that the scenes are very similar as the same set is reused, yet for some reason in one off them, the whole scene is really jittery. All animation is handled by the timeline as well and there are no external scripts effecting the scene. I also tried the obvious of duplicating the working scene and copying the broken one into it to see if it would work but to no avail.

Given the scene is set in a car, which the characters are parented to, I thought that would be the issue, and that something like a LateUpdate was required but I’ve tried various scripts on that topic with no answers.

The weird thing is that when I press go to next frame on the timeline, even though it has loads of time to update the image correctly, the jitter is still there. So when I flick through frames or press the timeline preview play button in the editor, it looks like stop motion.

Even for external shots when the camera is parented to nothing, and is animated using an animation made in the timeline, it happens.

I’ve attached an animated Gif which hopefully will shed more light on the problem113749-ct-glitch.gif
Though the car she is parent to is moving, the movement on the character in the image attached is entirely glitch driven as no keyframe data is active at this point on her.

Anyone have any similar issues with 2018.1?


We’ve seen similiar bugs where two timelines are updating the same object. That may not be the case here, but it looks like two things are having an effect on the position and their update is alternating every frame.
There is an open issue with Rect transforms showing this behaviour when transforms are animated with a constant curve. If these object are using Rect transforms maybe that is the cause?