Have I lost my project? Or is this fixable.

I started up unity with my game, and got the error telling me it could not load my layout. So I switched to the default. That’s no biggie as it happens every once and a while.
But this time, my project wont load properly. Other projects are fine, just not my most important one. The items in the hierarchy are still there, but nothing from the asset folder shows up. No scripts, no prefabs no nothing.
I looked in the project folder and found the assets folder still has all of its content, it’s just not showing up in unity.

Things I have tried:
Dragging all my assets into the project tab, restarting my computer, re-installing Unity, loading different scenes.

Also, in the console, for every single item that was in the project tab, there is this error:

Asset ‘Assets/Scripts/Upgrades/timy.cs’ is in timestamps but is not known in guidmapper…

Replace Upgrades with the name of any file that used to be in the project tab.

Any help would be extremely appreciated. Thanks

Have you tried deleting the Library folder inside your project from Explorer? Try that and let Unity rebuild your project.