Having a problem with materials imported from Blender

Hi all!

Im having a problem when I try to load my Blender model into Unity. My materials get all f’d up. I’ve included a picture to help you understand my problem. The red on the left and the right wall shouldn’t be there, they should just be white. The top line color (grey) on both the walls shouldn’t be there either. It should just be the same color as the rest of the wall.

This problem is around the entire house and I feel like it choose my red material to assign to every wall that did not get its right color.

PS: exported as .fbx file

I made my model in blender by extruding a plane multiple times. I assigned the materials by selecting the faces and then pressing ‘assign’ under the material itself. I’ve also done UV-wrapping everywhere.

Im quite new to blender and unity so Im not sure what Im doing wrong.
The materials that I created, did show up in the unity inspector though! But changing their color doesn’t seem to change the color of the according wall/floor.

I hope someone can help me out with this!
Thanks in advance!

That’s because you fbx file doesn’t contains any textures, just materials.

If you just want materials to be imported with your mesh:

  • Check Import Materials in the mesh import settings (click the .fbx file in the Unity Assets view)

If you also want your textures you have two options:

  • Install the FBXConverter software (official tool) then embed your textures to your .fbx file (they aren’t by default, hence the file size), now your .fbx file while increase and simply importing your file to Unity will do the trick.
  • Or, just create a “Textures” folder where your .fbx file is then copy paste your textures here. I recommend to create a new folder per mesh so that the Textures will always be the one of your mesh. See the manual in the Textures section.