HDRP asset does not appear in the create list with hdrp and core installed

Hey guys!

I am trying to get the new visual effects graph to work, first off I don’t know if this is normal but it does not automatically appear in the package manager. So I downloaded it from the GitHub repository at tree release/2018.3 which is linked to from the unity website. After downloading I imported all the packages using the + button in the package manager. It does give a bunch of errors including:

  • D:\unityFiles\ScriptableRenderPipeline\com.unity.visualeffectgraph\Editor\GraphView\VFXViewPreference.cs(74,67): error CS0103: The name ‘SettingsScope’ does not exist in the current context
  • Shader error in ‘Deferred.compute’: failed to open source file: ‘Packages/com.unity.render-pipelines.high-definition/Runtime/RenderPipeline/ShaderPass/ShaderPass.cs.hlsl’ at kernel Deferred_Direct_Fptl at Deferred.compute(80) (on d3d11)

and 182 more
only one of these doesn’t dissapear when clicking clear though.

after all this when I go to the create tab either from Assets>Create on the top or right mouseclick in project view>Create there is nothing like High Definition render pipeline with and without checking behind arrows (like with Shader>standard shader).
Anyone who has already imported etc the visual effects graph Could you maybe just tell me the process of how to get it to work? this would be very helpfull. Also, if you know what I did wrong please tell

Greetings Rafael

P.S. I used unity version 2018.3.0b9 which is the latest 2018.3 version and I also tested it for 2019.1.0a7

EDIT:

I though I might update a bit really quick. Not only the HDRP asset doesn’t appear, the visual effects graph doesn’t either and I also think the shader graph doesn’t either

I’m getting the same issue and it looks like I tried the same steps. I also previously tried 2019.1 but had way more errors.

D:/Projects/ScriptableRenderPipeline/com.unity.visualeffectgraph/Editor/GraphView/VFXViewPreference.cs(74,67): error CS0103: The name `SettingsScope' does not exist in the current context

Edit for the solution: there is a typo in the code, SettingsScope is missing an ‘s’, it the file needs to be edited at line 72 to be SettingsScopes.User instead of SettingsScope.User.

I’m currently having the same issue using Unity version 2018.3.0b8. Just cloned the repository at tree release/2018.3 and I’m getting that one error.

Here is LeapGamer’s answer, just putting it here so I can accept it as the correct answer:

“There is a typo in the code, SettingsScope is missing an ‘s’, it the file needs to be edited at line 72 to be SettingsScopes.User instead of SettingsScope.User.”

And Here is a full tutorial on how to get visual effects graph working By me:

  1. Go to Unity’s Visual Effects graph page
  2. Click On the “Download Now” Button at the bottom of the page
  3. Click the green “clone or download” button
  4. Click “Download ZIP”
  5. Choose a nice place to store the ZIP file, could be your downloads folder or somewhere else
  6. Unpack the newly downloaded file
  7. Start Unity Hub and make a new Project in version “2018.3.0b9” (or just open 2018.3.0b9 itself and create one there)
  8. When everything is loaded click Window>Package Manager
  9. Click the plus symbol
  10. Go to the directory where you unpacked the zip go inside the “ScriptableRenderPipeline” (Might contain some more stuff but will contain this) folder.
  11. open “com.unity.render-pipelines.core”
  12. Select “package.json” and click ok
  13. Do step 9 to 12 for the following files in this order: “com.unity.shadergraph”,“com.unity.render-pipelines.high-definition”, “com.unity.visualeffectgraph”
  14. Close Package Manager
  15. Click Internal>HDRenderPipeline>Add “Additional Light-shadow Data” (if not present)
  16. Click Internal>HDRenderPipeline>Add “Additional Camera Data” (if not present)
  17. Go to Project>Create>Rendering>High Definition Render Pipeline Asset and give it a name (good name is HDRP)
  18. Click Edit>Project Settings… and go to Graphics
  19. Under Scriptable Render Pipeline Settings click the round circle with the dot in it
  20. Select the newly made HDRP asset
  21. Click Player go to other settings and set Color Space* to Linear
  22. In the Project window navigate to Packages>Visual Effects Graph>Editor>GraphView
  23. open the “VFXViewPreference.cs” file in the text editor of your liking
  24. Go to line 74 and find the part of the code where it says “SettingsScope.User” and change it to “SettingsScopes.User”

Now you’ve succesfully added visual effects graph to your project, to make something actually appear do the following:

  1. Go to Hierarchy>Create>Visual Effects>Visual Effect
  2. In the Project view navigate to “Packages>Visual Effects Graph>Editor>Templates”
  3. Drag “Simple Swarm Particle System.vfx” to the Asset Template field in the inspector window
  4. Witness the magic happen in your Scene or Game view

Too actually create your own Visual Effects graph do the following:

  1. In your project view navigate to a place that is in the Assets folder
  2. Click Create>Visual Effects>Visual Effect Graph and give it a nice name
  3. In the Hierarchy view click one you’re visual effect object
  4. Drag Your newly made VFX graph into the Asset Template field in the Inspector window
  5. Double click your VFX graph or right click > open to open and edit it
  6. Do some Very cool stuff!