HDRP light source reflection

I'm having trouble disabling light source reflection.
consider this scenario:
7864312--998842--upload_2022-2-3_15-43-1.png
I have an area light but I don't want the light source reflection (the while rectangle) on the floor. and I only need the brightness of the light in scene.

P.S. The floor has a HDRP/Lit material with some smoothness. and I don't want to change the smoothness because I want reflection of other objects on the floor.

Any tips?

Try disabling "Direct Specular" in the HDRP settings or Camera Frame settings.

1 Like

Thank you, I was hoping for a method to disable/enable this effect per light.

Disable affect specular checkbox on your light

2 Likes

What onigiri said, I believe it's a recent thing and is only available starting from 2021.1.

1 Like

No, it's available very long time 7884472--1003177--upload_2022-2-10_6-13-19.png

2 Likes

[quote=“Onigiri”, post:4, topic: 870539]
Disable affect specular checkbox on your light
[/quote]
Thank you, I finally could find the checkbox. that one is inside HDAdditionalLightData component and we need to enable Inspector debug mode to see the options and disable the AffectSpecular checkbox.

You need to enable this https://docs.unity3d.com/Packages/com.unity.render-pipelines.high-definition@14.0/manual/More-Options.html

1 Like