HDRP not working on 2019.1 ?

On a clean project, I am importing HDRP and the Core pipelines in order to start a new project and I get the following errors:

Library\PackageCache\com.unity.render-pipelines.high-definition@5.13.0-preview\Runtime\RenderPipeline\HDRenderPipeline.cs(799,13): error CS0103: The name ‘CameraCaptureBridge’ does not exist in the current context

five times, each time in a different line of code. then I go to create in Project > Renderings and there is no such option so I cannot create the HDRP asset and then go to Graphics and assign it as the project’s rendering pipeline.

Anyone dealt with that ?

Solution found! (it works for me at least)

@Afassolas What I think caused issues for us, is that the wrong version for Shader Graph and Core RP Library was used in the project.

So what I did to fix the solution for me, was to remove Shader Graph AND Core RP library packages in the Package Manager window. Then removing HDRP, and reinstalling HDRP via Package Manager. This will automatically install the correct version of Shader Graph and Core RP library. Then restart Unity, reassign the HDRP asset in the Quality settings. Also removing HD Additional Camera Data script from my cameras in scene removed some errors (as these are not used anymore… I think).

Hope this solution works for you!


Original Post

I am having the exact same issue. Although, I have updated from 2018.3.11 + 5.7.2. Let me know if you can figure it out. I will do the same if I am able to fix the issue

@Afassolas I have encounter the same problem and you are the first thread that talks about it. It seems like either the Core RP is out of sync with the latest version of HDRP. Unless I am missing something.

I had the same problem. In order to solve this you have to check if the version of the following packages match:

  • Core RP Library
  • High Definition RP
  • Lightweight RP
  • Shader Graph

In my case, I updated all of them to 5.13.0. You can select the version by expanding the package and selecting ‘see all versions’.

I think the problem that is happening is that the verified (default) version of LWRP and its dependencies is 5.7.2, however updating the HDRP will install 5.13.0, causing this problem of mismatching versions.

None of these solutions worked for me. Even reinstalling Unity 2019.1.2 did not help.
But after many hours of fooling around i finally fixed it!

STEP 1: Close all Unity windows.
STEP 2: Delete all the contents inside these folders.

C:\Users\USERNAME\AppData\Local\Unity\cache
pm\packages.unity.com
C:\Users\USERNAME\AppData\Local\Unity\cache
pm\staging-packages.unity.com
C:\Users\USERNAME\AppData\Local\Unity\cache\packages\packages.unity.com
C:\Users\USERNAME\AppData\Local\Unity\cache\packages\staging-packages.unity.com

STEP 3: Open an existing project or create a new project to see if it works. (Unity will redownload all necessary packages automatically.)

I am still getting this error, having removed all render pipelines, doing a fresh install of high definition render pipeline. Gettting this error:

Library\PackageCache\com.unity.render-pipelines.high-definition@5.13.0-preview\Runtime\RenderPipeline\HDRenderPipeline.cs(382,13): error CS0103: The name ‘CameraCaptureBridge’ does not exist in the current context

and
Library\PackageCache\com.unity.render-pipelines.high-definition@5.13.0-preview\Runtime\Sky\SkyManager.cs(134,42): error CS1579: foreach statement cannot operate on variables of type ‘?’ because ‘?’ does not contain a public instance definition for ‘GetEnumerator’

I have had this same problem. everything in the scene just disappears when I update from 5.7.2 to 5.13.0. absolutely infuriating, especially when I have bean dealing with complications from updating to 2019

Thank you for the answer but look It seems like either the Core RP is out of sync with the latest version of HDRP. The Unity 2019.1 is packed with more than 283 new features and improvements. At the beginning of this post you will find a kingcitation.com/mla, followed by a detailed walk-through, of the major new features.

Still not working correctly on 2019.3.0a2, tried several versions of packages, still getting errors…anyone else experiencing the multiple CS1061 namespace errors - depending on the version of the package, I get different ones. Hard to hit a moving target!

Try to change the version of your XR Plugin Management to 3.2.13.

My Solution:

  1. Go to the package manager and remove HDRP package.
  2. Reinstall HDRP package.