[Help] I keep getting an error with blank message when I create a C# script.

First Problem:

I just started learning and using Unity but when I create a C# script, this error shows up:

alt text

I tried the following things but none of them worked:

  • Creating a new project.

  • Restarting Unity.

  • Uninstalling Unity and reinstalling it.

  • Formatting the computer so I start over.

  • Changing the display language from Arabic to English (I saw someone on the internet mentioning that this solved his problem).

I have not written ANY code yet. I have Visual Studio Community 2017. I also got MonoDevelop integrated with Unity (if that helps).

My Unity version is 5.6.1f1 Personal.

Second Problem

I get these errors (two errors duplicated) when I start a new project:

alt text

Although they disappear when I hit the Play button, they are still really annoying.

Thank you for help.

i have this error in 5.6 too

edit:
i solve my problem .
go to control panel>region > change location> in administrative tab change your home location to united state ! this solve my problem.

Try to remove the library folder in your project

I get this error when I build a project to my android device. (Samsung S8)

It happens in two different projects, using two different versions of Unity. (2018.1.8f1 & 2018.2.5f1)
Both projects use ARFoundation. (& ARCore and ARKit)

I don’t get the error when running in editor, but I do get it when building to device. I get the blank error which then prevents me from running the project either in editor or building. I then have to close the editor and re-open my project and it works as normal.