[Help] I keep getting an error with empty message when I create a C# script

First Problem:

I just started learning and using Unity but when I create a C# script, this error shows up:

I tried the following things but none of them worked:

  • Creating a new project.

  • Restarting Unity.

  • Uninstalling Unity and reinstalling it.

  • Formatting the computer so I start over.

  • Changing the display language from Arabic to English (I saw someone on the internet mentioning that this solved his problem).

I have not written ANY code yet. I have Visual Studio Community 2017. I also got MonoDevelop integrated with Unity (if that helps).

My Unity version is 5.6.1f1 Personal.

Second Problem

I get these errors (two errors duplicated) when I start a new project:

Although they disappear when I hit the Play button, they are still really annoying.

Thank you for help.

Make sure you computer can run unity. And try to close all programs except unity.

But my question is when you hit play button is there something pop up in your screen something errors like that? Becuase im so new in this problem. If there’s nothing ignore it i think that’s because of your comp or laptop.