Help needed, all AR apps crash on startup

At first I thought the error was with the project I was building in Unity, the option Google > Build and Run in Unity would successfully build the application but as soon as I allowed camera access the application would crash, then crash again on startup every single time.

After hours and tens of question pages I tried to download a different AR Core application from the google play store, turns out a lot of them are made with Unity and they are ALL crashing on startup, after I allow camera access.

Why is this especially weird? I got my new phone on purpose so I could start developing in AR, my old phone was Android 7 and so this is a brand new phone, new install, factory settings, I’ve installed and reinstalled Google services for AR, I have rebooted countless times, all AR apps keep crashing as soon as I give access to the camera

What is also weird it’s the same error for all the other AR apps, except the one I built gives an entirely different one, I will attatch the files with all the errors reported on crash.

Any ideas are appreciated, but it would help if someone familiar with the API and these kind of errors would take a look at them to explain what the hell is going on. Thanks in advance.[165351-ar-errors-on-camera-allow.txt|165351]

Edit 1: I just found this page from google, which might solve the problem

Edit 2: Good News! I was correct. All you have to do is go to your Player Settings for Android and change Scripting Backend to IL2CPP and then in Target Architectures select ARM64.

I am experiencing the same problems. A simple app that I’ve built for android a few days ago stopped working without changing any code or updating my phone. I’ve also tried AR elements app made by google and it hangs (does not crash tho), which makes me believe it is an AR core issue. If anyone has any info on this, please help.

@nems808 i have default settings of IL2CPP and arm 64 still my app crashes any idea what should I do?,Hi, I have default settings of IL2CPp and arm64 still my application crashes i am using unity 2022.1.17f1 please help me.