Help : New windows Update prevents Unity from Playing mp4 videos through video editor

I created a video editor to play 360 videos through Unity. However after updating my Windows ver 10 yesterday, I have no longer been able to play the videos. Keep getting the error

DllNotFoundException: Assets/Plugins/x64/avformat-56.dll

However the dll files are still in that folder. Tried a lot from redownloading the dll files to rebuilding .exe files to even reinstalling Unity. I am able to play the same videos through my player on another PC running the same source code through unity. Hence my guess is it has to have been from the update.

Anyone have a similar problem or have any idea whats going on? Help is much appreciated

Not sure if you are using Easy Movie Texture, but if you are, updating to the Oct 3rd update fixed the issue for me.

Edit: I went to the Asset Store window and hit update on the Easy Movie Texture package. It said it was updated by the author on Oct 3rd, but it doesn’t say why it was updated. However, it fixed the issue for me. Mind, that if you edited some of the prefabs, it may break your setup. It did in my case, and I’m having to rewire some stuff.

Let me know if it helps :slight_smile: Mark as solved if it does.