Help: Unity Project won't open. Stuck on projectBrowser.OnGUI.repaint

Title. the project was working fine until about 30 minutes ago. Then i edited my pause menu script to include UnityEngine.SceneManagement and load “menuScene”, I saved and came back to editor but it hung on the busy screen for 10 minutes saying ProjectBrowser.OnGUI.repaint, before i ultimately ended task. I restarted the program multiple times and waited 10 minutes to no avail. I restarted computer and it didnt work. Im unsure what to do to get back into the editor of my project.
Please help, thank you

Interesting the mention of SCM… I opened the SCM app and it had lost it’s credential. I signed back in via the SCM app, opened my unity project again and it got passed this screen.

Wow - pretty crazy it holds up opening the unity project!

Also using Plastic SCM and this is still an issue. Was able to resolve by opening the Plastic SCM app and relogging in. Pretty crazy it completely halted unity from opening at all. Serious issue here.

I had this problem today. I recently moved, which seems to have broken the connection between Plastic SCM and Unity. I was logged in on the web app to no avail. Here’s how I fixed mine:

  1. Create a new Unity project.
  2. Use the Plastic SCM tab to connect the new project to Plastic SCM.
  3. When the browser window pops up, log in to Plastic SCM using Unity ID.
  4. Return to Unity and close the window that still says “Sign in to Plastic SCM”.
  5. Observe that the project connects to a new Plastic SCM project.
  6. Open the old project that wasn’t working. It should get past OnGUI.repaint now.

The latest version of the Version Control package (v1.14.18/1.15.18) has a fix for Editor hang on startup for some projects that might address this issue for you.

If you can’t open the project to update the Package Manager, try opening the manifest.json file in the Packages folder and edit the “com.unity.collab-proxy”'s version field manually. Opening the project after editing the manifest should force Unity to pull the latest version of the package and (hopefully) resolve the issue.

I’m Having the same problem. I haven’t been able to open my project for 2 days.

i have one alternative fix i erased all the files in .plastic on the project is not ideal but at least i can OPEN my project

i just had the same problem, to solve it i just needed to combine the two methods that appear to work, open a new project login on plastic scm close it, in the project that is not opening erase al related to plastic, open the dead project now its alive!, but you are no longeer in the organization, then go to your recycle bin and restore al the plastic files you deleted and voala

Thanks for all the insight… I had the same issue… now fixed using SCM tricks as described!

Thanks for the helpful advice everyone, I was having the same issue but because when I migrated to Plastic it seems to have made 2 plastic accounts for my unity organisation and only one of those had signed out I had to use the Plastic SCM Client Configuration Wizard to log back in (for some reason the plastic scm app doesnt even have an option to logout without deleting your account credentials??).

Once I logged back in through the cc wizard the project opens again fine. This is the 3rd time this has happened to me, Plastic and Unity really need to fix this bug!

I hate Plastic SCM. It only couses problems. Collabrate was fine. Why they shut down it anyway ?
By the way restoring connection to plastic scm solved the problem for me.

This was happening for me too, I fixed it but I am not sure exactly what helped so I’ll list the steps I did :

After few unsuccessful tries to open Project_1, I terminated the last attempt from Task Manager.
I opened Plastic SCM, saw that I was already logged in there so not really something I can do.
Tried to open Project_1 again, got hung on the same thing again, terminated it.
Opened another project I had that didn’t have PlasticSCM source control. This other project opened successfully. I closed that project.
Then I opened Project_1 again and it opened just fine.

I have the same problem. I tried:

Editing the manifest.json file to change to version 1.14.18 and since that did not solve it to 1.15.18, but that did not help.

Opened another project (which opened fine) and then opened the hanging project again. Still hanging.

I would like to try the option ‘Open Plastic SCM and check login’ but how can I open Plastic SCM if my editor hangs? I only see the scene view, game view and hierarchy. Not the console or the plastic SCM window.