Help With Editor Camera

for some reason when my editor camera goes within a radius of a about five meters with any object, it will start to cut off the object if i go any closer. what do i do???

Make the Near Clipping Plane value of your Camera component a smaller value. Additionally, be sure that you actually focus on the object you wish to look closely at by selecting it, then with your mouse over the Scene view press F. This might be important, because it affects the nominal position between object and clipping planes of the cam. Try the later first, then check if your near clipping plane is 0.3, which is default, or make it smaller if you really need to.

Sounds like a clipping issue. Here is what you could try. Select the camera and look at its properties. You should see (assuming it is a perspective camera) a Clipping Planes property. Try setting the Near value to something smaller. The smallest you can get is 0.01.

Anything in between the Near and Far values is rendered (see this manual page). So if your camera is right up to the wall, it may be less than the Near value. That means it won’t be inbetween and thus not rendered. Note that the Near value cannot be zero.