Hey, My models are importing at 30x their poly count

Basically when I important my models to Unity, the model I have is 50k verts/polys roughly, but in the editor it’s 600k Verts, how can I fix this?

Do you have model compression on?

Are you sure it’s 600k for the one model? and not including everything else on the scene?

Try exporting the model to a fbx (if you’re not already) and importing that one.

Please tell us what software are you using and in which type it is after (fbx, blend, etc).
Also every type of file have got many options while it’s beign exported, for example while you exporting from Blender to .fbx it’s by default apply every modifier (so every subdivision survace you was using to bake from high poly is applied, also every object from scene is exported, also camera and lamps).