Heya, does anyone know how to make WorldSpace canvas Text less blurry/pixelated

I’m using a world space canvas in my Game with a TMPro object on it however it looks terrible for some reason. I’ve tried all the solution I could find such as Increasing the font size by a lot and scaling the objecect down, that did not change anything, I tried changing the font (i was using the standard TMPro one) the fonts changing filterMode to point via code, changing the font assets’ “character” setting to unicode and tried the different “rendering Mode” options all to no avail. Even turning off Anti-aliasing did not seem to help. Same story with increasing the “dynamic Pixels per unit” on my canvas.
I made an empty Project with just a cube and a WorldSpace canvas + TMPro to test it out and it still looks blurry.
The only thing that kind of worked was reseting the TMPro’s scale and changing the canvas’ scale to sth. crazy small however this seems like quiet a hacky solution and still does not provide perfect results. Anyone got an idea on how to improve this?alt text
Quality Settings are on Ultra and im using URP.
I’m always happy to provide further info / pictures.
Thank you for taking the time, cheers!

[172591-screenshot-12.png|172591]

Gladly,
I couldnt get this image to be of any higher quality because of the 524 kb limitation but for reference the text in the top UI bar looks clean in game. Its the text right above the turret which even in game is basically unreadable.

I think I know whats wrong. Go to the TextMeshProAsset you are using and make sure the font there looks smooth. Change the font settings, you should see “crisp, rasterize”, and some other options that should make it look better.

Alright, i have since tried loading up my project in Unity 2020.2.17f1 & 2019.4.12f1 ( I was using 2019.4.16f originally). The same issue persists across all versions. I have also tried about all the different options in the “Font Asset Creator” however none of them seemed to change a whole lot. The most noteable setting being “Render Mode” but none of the options provide a decent result.

can you take a screenshot of the problem