High GPU Usage

I have had this issue for a long time; my GPU is constantly at 100% usage while playing in the editor & in the build. No matter how many elements there are in the scene, but the usage is always between 90 - 100%. Profiler doesn’t show that high usage, I keep it disabled since it also causes pretty big perfomance drop but when it’s on it just shows that EditorOverhead & Gfx.WaitForPresent processes are using about 30 - 60% every frame. My Vsync is also disabled.

This is a common gpu driver issue with unity, you are probably developing from a high end laptop, i suggest you to go to your manufacturer site, and check what is the recommended driver version for your gpu, then install that one and dont upgrade it from for example the nvidia panel

@SamuelRoos The issue may be your Quality settings for V-Sync.
Try your build again after making sure that ‘V Sync Count’ is not set to ‘Don’t Sync’. Rather set it to ‘Every V Blank’. Hopefully that helps.