hotkeys problem unity 2018.2.2f1,unity 2018.2.2f1 shorcut/hotkeys problem

well hello I’ve updated my unity to 2.2f1 version and after that I tried to build some environment and I had some big problem…
all my shortcuts/hotkeys not working…!
all of them just stop works and I try to search on the internet about that and I saw that someone says to close the Asset Store window and its will fix, so I did it and its fixed but later on I opened Unity again and again all my shortcuts not working and my Asset Store window wasn’t open and I opened the Asset Store and closed it just to see if its will be fixed, and nothing… I cant use any of the shortcut/hotkeys…
if I trying to use shortcuts from the editor tab its works so I mean that my hotkeys not working…
ty for the help. :slight_smile:

I have the same problem on 2018.2.5f1.
Only restarting the editor helps me.

TL;DR: try to use the first shortcut with EN-US language.

I have the same issue in 2018.2.0f2 and find how to “fix it” for yourself. Maybe someone will be able to fix it too from my manipulations.

I have 3 languages at windows 10 (RU, EN-US, JP-IME) and when I start Unity it sets it to RU always (probably because it is main/default). This issue depends on it in some way, so I have 2 variants:

  1. Set language to EN before the first try of using any shortcut.

  2. Or if I forgot about it and shortcuts don’t work (because of this), I should press play, set language to EN (better a few times, back and forth), press play again (stop the game) and create a new empty game object by right click in the Hierarchy. Idk why, but after this, I am able to use ctrl+D on it and other shortcuts too. Also probably “Press play” can be replaced with “Build”, because sometimes shortcuts worked for me after build.

Changing languages order (EN-US first) in windows settings helps to not care about it on Unity start: just do not set another language before use any shortcut. After the first use, it is allowed.

The problem is still there Unity 2018.2.7f1 (64-bit)

Same here. Just all ctrl hotkeys stopped to work. Only restart helps.

Same, 2018.2.9f1 , ctrl + c and v

Same here. 2018.2.8f1 64bit (Win10). Restarting helps
Thought about updating it but according to the previous guy it doesn’t help at all :wink:

Same here

Creating a new game object helps.

Same here. Sometimes switching to Rider IDE and back helping, but still this problem is a freaking liability and slowers the work.
ps. system language is Russian, maybe this is somehow related to the problem.

same here , my keyboard has 3 languages , shortcuts don’t work & that’s a serious pain in the ass

Same, 2018.2.18f1

Fixed in 2018.3.0f2

same, 2018.8f1

if you use Collaborate try to sign out …in my case its work after logout.


Today I made a script that fix the CTRL+ issue on my unity 2019.4.20f1. Here is the link Feel free to copy paste it in your projects to see if it solve your problem.

Script: Put this script in a Editor/ folder somewhere... · GitHub