How can I achieve a perfect alpha cutout?

I have applied a Standard Shader with the Cutout Rendering Mode and I am applying a Projector on this Sprite with a blue circle texture/sprite.
If I turn off the Projector I have a normal situation:

But when I turn on the Projector I obtain this:

The blue circle is projected correctly but also the alpha of the Sprite is illuminated but I don’t want this.
What is causing this problem and how can I achieve a perfect alpha cutout (and avoiding the “triangle” in the bottom left)?

Thank you very much! :slight_smile:

im really not sure what you are talking about with “projector mode”. but you need to be carefull with image formats and compression. images saved out of paint programs can change actual image color data to make files smaller. it’s good enough for veiwing but it’s not good for developers and can produce weird result when your shaders are relying on specific pixel data.

with the small resoulution images that you are showing…
tip would be to NOT save images in any sort of JPG format and save your images in uncompessed PNG instead. also unity has different import settings for texture assets. find an import setting that does not loose fidelity either. from what you are posting this should solve your troubles