How can I change inspector tab settings for many objects at once?

I need to change import settings for mesh objects to:

  • Do not import animations (because it is set by default to Store in Root)
  • Set Normals to Calculate (instead of Import)

It can be a tideous task when you have more than a few objects.

You just select them (using Ctrl or Shift clicking) and set the setting and apply

Actually that just works for the first selected object but ignores the rest of the selection. I have the 3.4.0f5 version by the way, don’t know if it’s any different in a newer one.

I noticed this happens when I was using Unity 3 - free version. I guess it is one of the Full Software features.