How can I disable root motion during animation play?

Hello! I’ve imported an animated dragon from an Asset Store. It has a “Take off” animation. When playing it, the dragon moves up.

How can I stop this vertical movement?

What I’ve already done:

  • Disabled “Apply root motion” in the animator
  • Checked “Bake into pose” for “Root Transform Position (Y)”
  • “Root motion node” was already set to “None”, so I didn’t change it

But it still moves up both in the animation preview window and in runtime on the scene.

I also tried checking “Loop time” and “Loop pose” boxes. It changed the behaviour: dragon started to lower each time after moving up. But he still moved up during Take-off animation, so I reverted the “Loop time” and “Loop pose” changes.

What I am doing wrong, how to stop it from moving up?

Here’s a screenshot of current animation settings:

Is it actually root motion or is the vertical movement part of the animation? In which case you need to edit the animation and remove the (assuming Z) axis movement.