How can I edit a polygon collider2D?

I have all of my sprites together, and I am looking to have accurate collisions with other objects by using the polygon collider2D. When I add the collider and press edit, I am not able to change the collider at all. I tried holding shift, and that did not work. This has been a problem for a while, but now that I need it most, it is very important to have. I am on mac and using the free version of Unity.

For what it’s worth, I just encountered this issue and, for me, the problem was that I had two inspector tabs in my project workspace (even though neither set to Debug, which I had seen as a solution to a previous question).

Removing one of the inspectors made the “Edit Collider” button on the other one work…

  1. Select GameObject
  2. UnHide Polygon Collider and hit button Edit
  3. Now in scene view if you take your cursor over the points of collider they will get highlighted with light green.
  4. Just hold left mouse button and move points.
  5. If you need to delete a point , hold down the command on mac and then the if you take mouse over it it will get highlighted with red color , just left click and it will get deleted :slight_smile:
  6. Hope this helps you

@TriBolt72

For me it solved the problem by zooming out the scene view. If it is too zoomed in the handles for editing polygon are “behind you” so you have to zoom out in order to view them

Have your object selected > switch to scene view > click edit box on the collider component > drag and edit it on the scene view

Try toggling “IsTrigger” on/off, or off/on, depending on your situation. This cancels out the bug for me.

Activating Gizmos will help.

2021, version 2020.1.17*** and still the same problem, I can see one of the vertices/point for the collider, but can’t edit with drag/click. I can do “manual” editing by typing in the points section, but that’s a pain…the only one that does allow drag/click-editing is box colider…oh, and I can also add/remove points by clicking/ctrl-clicking on the green line.