How can I fix my blurry editor?

I have a blurry editor. Asked this on the forums too. Little advice hither and yon, but nothing has helped. My rig is solid, Unity worked fine until I updated to the new version. All drivers up to date. It is not my PC.

Could be one of many things. Have you tried:

Setting texture quality to Full Res?
Setting texture filter mode to Point?
Disabling texture mipmaps?

It might be possible that a graphics utility program (NVidia control panel, ATI Catalyst) is overriding settings for the Editor. Set texture filtering to Application-based instead of override, etc.

What things have you tried? “Little advice hither and yon” isn’t descriptive. Add a link to the forum thread.