How can I make the overall color pitch black?

And the only light is from what I provide?

Set the ambient light in the render settings to black.