How can I prevent the bloom camera effect from effecting UI text?

I have the default bloom effect on my camera, and I need my UI to be in world space, but when it is, it look like this

And I cant seem to find a material that makes it look plain white without the glow/bloom

Use a different camera for your UI. I generally recommend doing this anyway as it helps in a variety of other situations as well.

Using a different camera is not an option when you are dealing with the HUD (I’m building a simple HUD for my google cardboard project, and the UI needs to be in world space). What I end up doing was create a new material and tone down the saturation. It doesn’t exactly remove the bloom; just tone it down so that it is not noticeable.

100294-2017-08-21-13-36-57-duckseasonvr-microsoft-visual.png

Still you could use a Different camera showing only the UI layer. You could also put your world space canvas into the UI layer then
Tell camera “show only UI layer” and “Do not use post processing” and vala, it should work.