How can I re-enable physics in Unity 3.2?

I just upgraded from Unity 3.1 to Unity 3.2 and now I can't get physics to work. To be clear, the symptoms are as follows:

  • Gravity doesn't work. I checked in the physics settings menu and gravity has been set to (0,-20,0) but objects with rigid bodies attached do not plummet as expected; they don't move at all.
  • Update() is still being called on the objects every frame.
  • FixedUpdate() is being called on the objects only once.

To be sure that it wasn't a problem with upgrading my project, I started a new scene with two objects:

  • a floor with a collider and a rigid body checked isKinematic and unchecked useGravity
  • a box several units above the floor with a collider, a rigid body checked useGravity and unchecked isKinematic

Same result.

Okay, found the answer in the middle of writing the question, but I thought that it might be helpful for others with the same problem.

For whatever reason, Time.timeScale was set to 0. To re-enable normal behaviour, set Time.timeScale to 1 in an Update() script.