How can I recover unity project from app build?

Hi. So I have a .app file I have built for iOS and Mac operating systems, and it works when I run it. However, I have lost all my project files and cannot edit or change my game. Is there a way for me to sort of…“unravel”, or produce the unity project out of the application file? If so how? Any help would be much appreciated.

I don’t think you can. It compiles it into files for that certain operating system or version. Gets rid of unnecessary crap to reduce file size :confused:

Usually, you have to take apart your built .app or such and then you get pieces which can further be taken apart and the assets and scripts recovered from it.

I know (Didn’t backup my stuff and had a working PC/web/android version, but no project… Have started backing up religiously since then.)

Google these tools such as : Unity Assets Explorer, Unity3d Obfuscator, and Unity Asset Explorer
Hope they help you get your work recovered. :smiley:


I found this anwser on Quora:

Contrary to popular belief, it is possible to get the compiled code and assets from a built version of the Unity game. If you ever happened to create a build you can use tools such as ILSpy or dotPeek to gain access to the code. For assets, you can use Unity Asset Explorer. Just search that up on google and I’m sure you’re capable of finding it. Else, I’m afraid it is truely gone forever assuming you didn’t leave the project in the recycle bin on windows.


Once you have downloaded either ILSpy or dotPeek, navigate to the “managed” folder of your game build, and open the ‘Assembly-CSharp.dll’, ‘Assembly-CSharp-firstpass.dll’ and ‘Assembly-UnityScript.dll’ files with either of these programs. You shouldn’t have a hard time finding all your code from there.

As for assets, using unity asset explorer, it is pretty straightforward to get your assets. I reccomend reading this article: A practical tutorial to hack & protect Unity games - Alan Zucconi

It will show you how to do everything I mentioned above.

I tried it and I got the code back, but I didn’t try the assets yet.