How can i remove skybox reflection on my terrain

he is how it looks


those are clouds reflection

Set glossiness to zero.

I know this is an older post but I kept coming across it while trying to find an answer. For future readers - what fixed it for me was going to the affected textures used in the terrain and setting their “Input Texture Alpha” setting to “None.”

This forum helped me figure that out - https://forum.unity.com/threads/question-overly-reflective-terrain-textures.487101/#post-3175371

Edit: Another solution I found: make sure the terrain’s material is set to diffuse and not standard. Standard was causing skybox reflection for some reason.