How can I specify a "root" bone (Mixamo -> Blender -> Unity)

Hello, I have imported many Mixamo animations into Blender. The root bone of the armature from Mixamo is the Hips bone. So when I import the model with animations into Unity, and create a humanoid avatar, it sets the position of the model to the hips. And when the model is animated in game the hips do not move but the rest of the model is animated. (i.e. I have an idle animation where the feet should be planted around but the hips sway around slightly. Instead the hips stay still and the feel shift around on the ground). Is there any way to specify a “root” bone? I can’t seem to add a root bone in Blender for some reason. And even if I could, I can’t find an option in Unity that would allow me to specify that as the root.

You need to select the mixamo fbx in the project view and then open the rig tab. Set it to Humanoid. Then open the animation tab, scroll down to Motion, and select the node.

177081-root02.png

Question: Is the origin set to the feet in Blender or is the origin in the hip bone? Make sure it’s at the feet. transforms - Change pivot or local origin of an object - Blender Stack Exchange.

I ended up fixing this by switching the avatar to none, and then re-generating the humanoid avatar. I love unity but I HATE the 3D model import process. I’m going to close this. I don’t consider this a real fix because I don’t understand why it fixed it.