How can I stop the terrain grass from arbitrarily changing color?

I can’t believe I’m having to tell Unity to not arbitrarily change the color of my grass for no reason. What a ridiculous issue to have.

None of the fixes other people have suggested has worked. Changing WavingGrassInput in packagecache of course just reverts the file back to the repo version. I’ve tried includes and they don’t seem to do anything with this either. Adding a modified TerrainEngine.cginc to my project was also fruitless.

Does anyone have a solution for this issue, or am I just stuck with psychedelic grass?

Note to the folks at Unity who make these types of calls: If we don’t specifically design an effect or tell Unity to do that very specific something, please don’t just decide to do it for us. And if you do decide to make something very specific like this the default, for the love of Cerny just add the option to turn the thing off. This took what should have been a 30 minute process and turned it into a 2 day comedy of design flaws that never should have been an issue to begin with.

Any help is massively appreciated.

I agree with you on this matter. Is there a reason why we cant toggle this off? I’m facing this issue a year after this thread has been created. I’m a bit disapointed.

This issue still exists and it comes randomly