How can I use "vuforia" and "etcetera" plugin together?

I want to use both “vuforia (Qualcoms AR plugin)” and “etcetera (plugin way to use iOs photo gallery)” plugin in one project.
But when I tried to use both plugin together, I could not compile Xcode project by
"Apple mach-O Linker Error " .

I confirmed each plugin work well in each projects.
But they don’t work in one project.

Are there someone solved this problem?

Although I’m not using etcetera, most likely you’ve got same issue I did. I just made it work with latest Unity 4.2 and Vuforia 2.6.7.

Few probable things that could be causing the issue:

  • Folder hierarchy: This is the biggest most likely point. Leave it as it is when imported from the packagefile. If you move a single file out of its original place, with a few exceptions, you will get many errors as you’ve described.

  • Folder naming: Although I apparently had no issues here, use no spaces. It’s advised everywhere (despite the package itself unpacking folders with spaces on it…).

  • Build Settings / Player Settings: Again, I had no issues here. And I’ve tried changing them a little on an empty project, which worked with no issue. But, having the wrong setting here can cause such linker errors. Create an open project and try around.

To try again after changing any configuration, use CMD + SHIFT + B and press on Build and Run. It will ask where to save and, if saving on top, select Replace.

And good luck!