How can you hide Canvas objects using Camera Culling Mask?

I have a second camera that takes screenshots when a user finishes a level. When this happens, I switch the camera in the canvas Render Camera (worldCamera). This is all fine and dandy, but putting UI images on different layers, and removing those from my camera culling mask doesn’t work.

The canvas is in Screen Space - Camera mode. I believe the issue is Unity only considers the parent Canvas layer, and not the hierarchy object layers. So it only either renders the whole UI layer, or nothing.

Any idea on how to bypass this behaviour? Or maybe I am missing something?

I just disabled the images :confused: