How do I cancel baking??

Hi, I fucked up somewhere baking a NavMesh and even though it’s exactly how I want it it’s baking some other thing that I don’t know and I can’t use the editor until it’s finished. Normally I would let it finish, but the ETA is 90 hours. I just want to cancel the baking but I don’t know how?? Everytime I open it automatically starts baking and lags my whole computer.

I had the same problem.
In the lighting window (near navigation) uncheck the “Auto Generate” checkbox.
That worked for me. Don’t ask me why.