How do I control particle orientation? (legacy vs shuriken)

I need to orient my particles locally, and I know exactly how to do this with the legacy particle system, but not shuriken. The old way, I would set the billboard type to horizontal, uncheck “simulate in worldspace,” and rotate it. I’ve tried to do the equivalent in shuriken (set the billboard type to horizontal, set simulation space to local, and rotate) but it’s not working. Is there something I’m doing wrong?

Here’s a video I capped of the legacy orientation working as I need it to, and the shuriken orientation not working:

Thanks in advance!

Welllll, I think I may have found my answer…

Upon trying a few more options, I’ve found the best way to achieve what I’m after is to switch the render mode to “mesh” and choose a plane. If you import your own low poly plane, the tri count and draw calls are exactly the same as a particle (according to the stats).

Hope this helps anyone else having this problem!

Some sub-components of Shuriken have a simulation space property, which can be Local or World. It’s not global like in the legacy particles, which is much more robust but also easy to miss.

Hope that helps


For those who may want some example code on how to orient particles: