How do I disable all colliders of objects all grouped under a single parent gameObject?

So you necroed a 2 year old thread to post unformatted code?

Check this thread out for proper usage of code tags:

Also I find your naming convention a bit odd:
m_Collider

The m_ prefix isn’t a requirement in any respect. And honestly it doesn’t even hurt here. It’s just that the common practice of using ‘m_’ is to denote “members” (hence the m). Meaning it’s a member variable of ‘this’ (otherwise called a ‘field’).

In your use case though, it’s not a member variable. It’s a variable scoped to the loop.

If you’re just using this because you’ve seen it before… you’re misusing it. Anyone reading your code will be confused expecting it to be a member variable, but it’s not. And since common coding conventions like these only really serve the purpose of conveying information to the reader of your code, it’s failing at doing that.