How do I get objects to cast shadows on each other using BEAST?

On unity3b4 (basic license) I'm using the new lightmapping tool.

I've managed to get some decent enough looking shading out of it, but have noticed that the objects aren't casting shadows on each other (the rocks don't cast shadows on the ground for instance).

I've been reading the docs and I cant work it out. Does anyone have any idea what I'm doing wrong?

It works for me, so I'll give you some possible solutions.

  1. The objects aren't marked as static, and therefore won't be baked.

  2. You have a light marked as realtime only.

  3. I've found in Basic, (I can't speak for pro) that lights, by default have shadows turned off. Go to each individual light and turn shadows to whatever you want. Don't worry about the realtime settings, I haven't noticed any differences in the lightmaps based on the realtime soft or hard shadows.

If none of these work, you might have a bug, or maybe I missed something.