How do I get smooth edges for a voxel game?

This is the image I’m trying to replicate in my game:

Notice how for the most part the edges are rendered nice and smooth.

This is what is happening in unity:


See how most of the edges have those really bad lines?
What settings do I need to change to get the edges smoothed out?

You just need some anti-aliasing!
You can enable this in “Edit > Project Settings > Quality” and enabling Anti-Aliasing from there.

There’s also a script in Unity’s Standard Assets to add Anti-Aliasing effects to a single camera at: “Assets/Standard Assets/Effects/ImageEffects/Scripts/Antialiasing.CS”

But the Quality Settings are probably the best way to go unless you’re working with multiple cameras that need show different effects.

I should mention that it also looks like there’s some Ambient Occlusion going on in your referance image. This too can be found in the “ImageEffects” folder as a script.
Hope this is what you’re after!