How do I get the crisp sprite look?

I’m trying to figure out what I need to do to get pixel perfect graphics for a 2d game I’m working on? When I bring my png file over to Unity, I lose quality when I increase the pixels to unit from 100 to 250. I thought that downscaling wouldn’t hurt the quality. I’ve tried it with multiple sizes of the same graphic. I’ve used 128x128, 512x512, & 1024x1024.

Here are my import settings:
Texture Type: Sprite
Sprite Mode: Single
Packing Tag:
Pixels to Units: 250
Pivot: Center
Filter Mode: Bilinear

The sprite in the pictures below is 512x512.

Below is what the image looks line in game view at the 250 Pixels to Units.


This is what the original file looks like (below).


My question is, how do I get the smooth edges like I have in the original file? I’ve attempted to change filter modes and other setting to see if it would help and it didn’t. It also might be worth noting that if I change the Pixels to Units to say 50, the lines are more clear that when the Pixels to Units are at 100. I know that it’s probably something simple that I’m doing wrong. Ideally I would like this to work for multiple resolutions too. Any advice is greatly appreciated. Thanks!

Sorry for resurrection but this can maybe help someone. You can always use Generate Mip Maps options for that kind of problems. Also overwrtiting Max Size and Format as your image export can decrease crispy look. Mip Mapping - polycount

The answer that ended up working for me was that I needed to change the compression from “Compressed” to either 16-bit or Truecolor.