how do i keep a sprite on a plane from flipping around when colliding?

Hello, I’ve been working on this game for a while and its coming along but I have had this issue with sprites and collision. It is very annoying.

What I’m trying to do: A sprite character made on a plane that moves N,S,E and W.
What the problem is: The sprite when colliding with an object will flip around uncontrollably.

I have tried rigid body with kinematics, but i want the sprite to collide and stop. i tried with gravity but it will flip flop around. And freezing positions helps a little but it still rotates the “character” and often makes it pass through the object.

I’m willing to use other methods of anyone has any ideas.

I froze the rotations as sugested but it now passes through objects as if they were not there.

lol, u need to freeze rotations. it should be an option in the rigidbody thing

Have you tried freezing the rotation of the rigidbody on all axes? That will prevent it from rotating due to collisions.

When i freeze the rotations, the object will pass through walls and other objects.