How do I make my leaves cast shadows?

Now, I don’t know how noone seems to have asked this yet, maybe there’s a better way to do this and I’m the only one with this problem.

I’ve made a material for my leaves, and it’s set to transparent since the texture has transparency around the actual leaves. Now, since I have to have the material set as transparent, it doesn’t cast any shadows. How do I work around this? It seems so simple, and maybe it’s just me being dumb but I can’t figure out any way to do it.
I’m using URP if it helps.

Thanks!

This highly depends on the shader your material uses, but in general this is absolutely possible.
What shader do you use? Could you post a screenshot of the material?

In case your leaves are meshes, you might have the “Cast Shadows” Boolean not activated within your MeshRenderer component, or your camera might be too far away from the leaves to render any shadows.

If nothing casts shadows at that distance, check your shadow settings and cascades within your Universal Render Pipeline Asset (the quality assets for your URP).