How do I make refraction visible in 2d mode?

I’m making a pond in a top down game using the standard stained glass distort material and the refraction is only visible in the scene window. When I click “2d” in the scene window, the distortion effect vanishes and it is never visible in the game window (with orthographic camera).

I’m guessing that the normal map is distorting along the z-axis and is thus invisible when only viewing x-y.

How would I make this distortion visible in 2d mode.

I was looking for an answer for this question and I just found a solution;
so that you can use the Stained BumpDistort Shader visible in 2D.

Do following steps:

  • make sure your “Near” parameter of your Camera is not 0; set it to -1 or +1 or just play with it.
  • you should be seeing your particles kind of black or dirty.
  • then play with your distortion ammount, it should be a pretty low value to be calibrated in 2D mode.
  • For me it works perfectly in 2D by following this steps

Hope you too![89178-unitansdist.jpg|89178]