How do i make UI (any text) to be affected by scene lighting? 2D

I have tried searching for solutions and people suggested things along the lines of changing the material shader to:

TextMeshPro/Mobile/Distance field (surface)
(the image shows TextMeshPro/Distance field (surface) but the results are the same for the Mobile version as well.)

(initially it was TextMeshPro/Distance field) However, the text turns into magenta which shows that there is an issue.
shader issue?

There were also posts saying it was an issue that wasn’t fixed… but posts were a few years old so maybe there is a fix now?

What’s your render pipeline? Could it be that the shader is not compatible with it?

Currently on URP with the “Renderer2D” in the renderer list…

I really don’t know much about the shaders and such so not sure if that is the issue.

Edit: I just checked using the normal usual “Universal Render Pipeline Asset_Renderer” in the renderer list instead and then I got a different issue of 2D lights not working… so doesn’t seem a viable solution.

I think that you need to set your canvas from “Screen Space - Overlay” to “Screen Space - Camera” for it to properly register lightning and post-processing effects.

Hi. Thanks for your feedback. However; I had my canvas setting already in the “Screen Space - Camera”…

As far as I can tell. It seems I need to get the SDF? shaders for the text mesh pro from something like the text mesh pro 3.2.0-pre.6 or something ( I can’t remember exactly) which apparently is a pre-release but I couldn’t find it in Unity 2022.3.9 so I assume i would have to use a unity version where i can find the - said shader…