How do I resolve issues connecting to the licensing server?

I’ve been using Unity for years and haven’t had a problem with the licensing… until now.

I upgraded to Unity 2017 this weekend, but cannot get the thing to activate my license. Every time I try, it says it’s unable to contact the license server.

I’m on Windows 10. I don’t use a proxy. I’ve added a rule to my firewall and even disabled the entire firewall. I’ve disabled my antivirus. I clicked the link for more information and it says all services are up, and I can access every unity service via browser (seen in the screenshot). I even tried deleting the ULF files. I contacted Unity and rather than responding, they silently suspended my account, with no notice! I’m at my wits end… any ideas? 100 rep reward to anyone who gets me on the right path.

Edit: A few more details: I’ve been seeing this 24-48 hours, so it doesn’t appear to be a true ‘wait until later’ issue. The ‘click here’ link leads to the status page in the background. The FAQ and Help links are pretty much useless.

Okay, so after playing around with this for a while, I finally got it to work. I’m going to detail the process below in case anyone has a similar problem:

1.) Completely disable your firewall and antivirus. An outbound exception is not enough (tested).
2.) Delete the ulf files in C:\ProgramData\Unity. These contain your cached license activation. Deleting them forces Unity to reset activation and ask for your keys/login again. (Note, this may count against activations… you may need to call Unity support if you do it too often, not sure).
3.) Open Unity. When it asks for your license key, put it in. Instead of saying “Service not available”, it should now say “Server returned an unexpected value”. This is good.
4.) Without closing unity, disconnect your internet connection (either disconnect from Wifi network, or pull your ethernet cable). Unity should automatically switch to offline activation.
5.) Generate the file for offline activation. It’s the button on the right with the current build.
6.) Reconnect the internet. Click the link in Unity for manual activation.
7.) Follow the steps for manual activation. It will have you download a new file.
8.) In Unity, click the left button to choose the file. It will activate and allow you to use Unity.
9.) Problem solved!

Hope this helps someone.

Lol, I just relaunched unity hub (after downloading unity 2019.2 in my new laptop) and it worked. Sometimes, the problem is, firewall blocks these apps for security reasons so you gotta make sure that didn’t happened.