How do I rotate (90%) a .jpg texture on a flat surface?

Some of my imported texture images appear incorrect in the scene and main camera views. They are rotated 90%. The orientation in the import settings view appears correct.

you’ll have to rotate the object or Plane it’s on via the Transform settings.

or if it’s incorrectly added on, you may have to re-texture it in your modeling software.