How do I set up an Android device for Build & Run?

I successfully ran Build on my project and loaded it manually on my phone. It installed and loaded successfully.

When I try to do a Build & Run, I get an error about my phone not being set up. I have tried to set up my device in Eclipse, but am not sure if I’m on the right track.

In Build & Run I get to this step:

“Getting list of attached devices”

“Trying locate a suitable Android device…” (Yes, the typo is in the message.)

And then I get this Build failure message:

“Unable to kill the adb server. Please make sure the Android SDK is installed and is properly configured in the Editor. See the Console for more details.”

In the Console it says:

C:/…/sdk/platform-tools/adb.exe kill-server

stderr[ * server not running * ]

stdout[ ]

Any help setting up my phone for Build & Run would be very appreciated.

These question may help you figure out the problem:

  1. Have you installed the latest Android SDK? If yes, re-download it. (I know this seems irrelevant but sometimes it works)
  2. Locate //Platform-tools/adb.exe. Go to the installed SDK location in command prompt. Type “adb devices”. Check if you see your device in the list.
    Try these steps and let me know the result.

EDIT: It says adb server not running. So “adb devices” will automatically restart server.

Plug off your data cable and press alt+ctrl+delete and then select ‘Processes’ kill the process by the name ‘adb.exe’ and then plug in the data cable of your device. Now ‘Build and Run’ will work. Hope this helps.

your anti virus could cause it too…

I followed the steps in

https://nookdeveloper.zendesk.com/entries/21943338-NOOK-Developer-Start-Up-Guide#_Install_NOOK_SDK_Addon

but even then, I had to troubleshoot getting windows to see the device, I had to uninstall and then get the update from the nook developer website. it all explains it in that link above.

It took a few hours to figure it out

I had that problem when my device was plugged into usb 3. I changed to 2 and it worked fine?

Random I know but true.

  1. locate your platform-tools
    Mine is located here:

X:\XXX\AndroidSDKTools\platform-tools

(I renamed and changed the default location, your location will be different)

2.(Press Shift+Right-Click) adb.exe (open command window here) (type) adb devices
What you are doing is opening a terminal from the adb.exe from location.

  1. Unplug the Shield and when it reestablishes a connection, the Shield will Prompt you to authorize device. Check Yes.

And you have to uncheck “Google Android Project”

None of these answers helped me. This did: Tutorial: Manually installing Android ADB USB Driver