How do I stop gameobjects from going through each other in the scene unity3d

I having a problem . The enemy ai’s are going through each other . In the scene . I have sphere collider attach . I also added a mesh collider and nothing change. How do I put an end to this ?

Your collider is set as trigger. That means it wont stop objects. Try to uncheck the “Is Trigger” checkbox,