How do the camera motion blur exclude layers work?

I have the camera motion blur imagefx applied to my camera and i have the player character on a seperate layer… I select the player layer in the camera motion blur exlude layers just like described in the manual but it does not work. The only thing that happens is that there is no motion blur at all… When i remove it again from the excluded layers the motion blur is back on but of course also blurs the player character…

Is there something else i need to do to make it work as expected?

Hi @Becoming

There’s a simple work-around for this. I have copied my main camera, set the culling mask to your character (or whatever else you don’t want to blur) and remove the motion-blur image-effect. Make sure to uncheck your character layer in the culling mask for the camera that has the motion-blur image-effect. Now you put the Clear Flags to “Don’t Clear” and finally the Depth to be bigger than the depths of your motion-blurred camera so it will stay on top.