How do you disable Gear VR?

Ever since the 5.5.2 release, my 2D development packages have been prompting (and will not load) unless I setup Gear VR.

I don’t have VR enabled, so this is somewhat vexing.

Try this:

  • Enable VR support
  • Remove Oculus from the Virtual Reality SDK list (or better make sure the list is empty)
  • Disable VR support

90589-vr.png

Edit: As mentioned in the answer by @tk_musopia recent versions of Unity 3D before disabling VR support “None” should be added to the list of VR SDKs in addition to removing other VR platforms from the SDK list.

So, even after removing all SDKs and the Virtual Reality support checkbox in preferences it was still loading to VR in Android. Seems like maybe a bug?

I had to go into the unity application folder and remove the UnityVR and VR folders and restart the app. Now it does not compile with VR automatically.

In our case, removing Oculus was not enough but we also had to add “None” as the only element in the list, and after that disable “Virtual reality supported” as @guneyozsan stated above. Seems like a bug to me.
alt text