How do you fix terrain grass getting darker with distance?

The grass seems to step darker using distance from the camera. I don’t know what is causing it and I have tried playing with all of the terrain settings to no avail.

Doesn’t entirely fix the problem, but I’ve tried making the grasstexture image a desired color instead of using white and having unity color them using the healthy and dry color settings and it doesn’t darken nearly as much and as close.

Check your Grass’s material.

Set Shader to “Shader Graphs/TerrinaGrass”

and you can tweak Distance Fade to change color according to the distance.
By default, “Fade Color” is Black, so you can change the Fade Color to your desired color. (Mine is Green)

You can also change “Distance Fade Start” and “Distance Fade End”