How do you Force commit on asset server?

I started working on a new feature and made a couple commits then realized this was not going to work. So I used Assets Server to revert to a earlier version. Then I made some new changes and tried to commit but assets server won’t let me commit because I do not have the updates later than the revision I reverted to. I don’t want them, that is why I reverted. How do I force assets server to commit what I have now and make this the new current version?

Cheers,
Grant

edit: current solution I am trying is copy project (as back up) and then make new project in Assets server and just lose all asset history before now.

Easiest fix is to create a new project on asset server and commit to that… Asset server/Unity combination has been unable to ignore changes on server for at least 3 years… I wouldn’t wait for it to be mended… :wink:

You can still update. If there are any conflicts (and there probably will be), just select “Ignore server changes” for all of them.

You will run into more problems, though, if you renamed or created some folders, then he will ask you to either rename the server’s or your locals. Don’t remember which was the best option, I think both have their drawbacks.